WARN: old systemd (< v232) detected, container won't run in a pure cgroupv2 environment! Please see documentation -> container -> cgroup version

Proxmox from v6 to v7 error when starting LXC:

WARN: old systemd (< v232) detected, container won’t run in a pure cgroupv2 environment! Please see documentation → container → cgroup version.

Solution:
Edit the grub on the Proxmox 7 server.

nano /etc/default/grub

Searches for the parameter GRUB_CMDLINE_LINUX_DEFAULT

and add the fallow config quiet systemd.unified_cgroup_hierarchy=0

The line need to look:

GRUB_CMDLINE_LINUX_DEFAULT=“quiet systemd.unified_cgroup_hierarchy=0”

Then save and in the command line

Code:

update-grub

start and connect one
Code:

reboot

This probably causes the CGroup version to be set back to version 1. PVE7 seems to only use version 2.

Also another Solution is to either install new systemd or migrate your machine to CentOS8 or something newer

For more help ask Proxmox support